#325 ✓invalid
Jan Becicka

Cannot mount Image

Reported by Jan Becicka | March 25th, 2013 @ 05:08 PM | in 1.2.0 Release

~/source/libimobiledevice/tools:ideviceimagemounter -d -x /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/6.1\ (10B141)/DeveloperDiskImage.dmg Copying '/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/6.1 (10B141)/DeveloperDiskImage.dmg' --> 'PublicStaging/staging.dimage'
done.
Mounting...
Error: ImageMountFailed

I'm on Mac.
Git revision b2924a1549d874fb86deaad5fd2438e567c65bf4
Thanks

Comments and changes to this ticket

  • Alexey Storozhev

    Alexey Storozhev May 23rd, 2013 @ 02:53 PM

    On Mac it's hard to have unmounted developer image.
    afaik ImageMountFailed error happens when image is already mounted

  • Martin S.

    Martin S. July 1st, 2013 @ 04:01 PM

    • State changed from “new” to “invalid”
    • Tag set to ideviceimagemounter, libimobiledevice
    • Assigned user set to “Martin S.”
    • Milestone set to 1.2.0 Release

    This looks as if you had already mounted the image... then mounting again will obviously fail.
    You can not unmount images using ideviceimagemounter or the underlying protocol as this option is simply disabled.
    What you can do is to reboot the device, this removes any mounts.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

A project around supporting the iPhone in Linux.

See http://libimobiledevice.org

People watching this ticket

Pages