#320 ✓invalid
r0941703960

Use idevicebackup2 backup has error error code -1

Reported by r0941703960 | March 7th, 2013 @ 01:17 PM

I had installed libimobiledevice-1.1.2,
and i wanted to backup iphone(JB, ios6.1.1, ubuntu:12.04),
the command :
mkdir bk
ubuntu:~$ idevicebackup2 backup bk
Backup directory is "bk"
Started "com.apple.mobilebackup2" service on port 55591.
Could not perform backup protocol version exchange, error code -1

then i output the idevicebackup2 log,
it show " ERROR: Backup directory "BACKUPDIR" does not exist! "
so how do i to order the Backup directory to run backup?

Please help me, thank you!!

Comments and changes to this ticket

  • Martin S.

    Martin S. March 18th, 2013 @ 05:01 PM

    • State changed from “new” to “invalid”
    • Tag set to ubuntu 12.04, idevicebackup2
    • Assigned user set to “Martin S.”

    You need at least libimobiledevice 1.1.4 or even later for proper iOS 6 backup support.
    Feel free to reopen if you test it with the latest version and it still fails for you.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

A project around supporting the iPhone in Linux.

See http://libimobiledevice.org

People watching this ticket

Attachments

Referenced by

Pages