#238 ✓resolved
Sam Bingner

[patch] libimobiledevice will not compile with clang

Reported by Sam Bingner | October 12th, 2011 @ 09:33 AM | in 1.2.0 Release

libimobiledevice would not compile because config.h was not loaded in debug.h so it was never actually using the #ifdef statements properly. It was also inline-ing away the debug_buffer call - so I simply removed the inline from that function. Not sure if that is the correct fix or if it should go to debug_buffer_real etc, but at least it makes it work.

Comments and changes to this ticket

  • Martin S.

    Martin S. March 19th, 2013 @ 05:12 PM

    • State changed from “new” to “open”
    • Tag set to mac os x, clang, libimobiledevice

    Thanks, but I don't think this still applies or?
    Compiling with clang appears to work fine on OS X for me.

  • Martin S.

    Martin S. May 27th, 2014 @ 09:14 AM

    • State changed from “open” to “resolved”
    • Assigned user set to “Martin S.”
    • Milestone set to 1.2.0 Release

    Fixed in git HEAD.

    This ticket tracker is deprecated as we've moved to github.com/libimobiledevice.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

A project around supporting the iPhone in Linux.

See http://libimobiledevice.org

People watching this ticket

Attachments

Pages