#351 new
Hristos Giannopoulos

zip_open when using ideviceinstaller

Reported by Hristos Giannopoulos | August 12th, 2014 @ 06:34 PM

I am trying to install a .app signed with the proper Developer credentials, to an iPhone 4s running iOS 7 from OSX Mavericks. Originally I had installed the libimobile tools through homebrew, and everything was working smoothly. However, due to homebrew's issues running alongside macports, I decided to explore alternative installation methods.
I found https://github.com/benvium/libimobiledevice-macosx, which appears to install fine. I can call idevicesyslog and idevicescreenshot and both act as expected. However, when I go to install the .app to an iOS device, (the same way I was when having installed libmobiledevice with homebrew), I get the following:
ERROR: zip_open: /usr/.../appImTryingtoInstall.app: 5

I understand that this OSX version of libimobiledevice is not official or completely up to date. If that is the most likely problem I will go back to the homebrew installation.
I run the command
ideviceinstaller -U (UUID) -i /path/to/app/appIWantToInstall.app

No comments found

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

A project around supporting the iPhone in Linux.

See http://libimobiledevice.org

People watching this ticket

Pages