#272 open
Hajo Baess

iPod Touch 4G cannot be mounted, but is recognized in Nautilus

Reported by Hajo Baess | May 31st, 2012 @ 07:32 AM

I am stuck trying to mount my new ipod touch 4G to my Linux Mint 12
machine, although I got pretty far: it is "seen" in Nautilus, but it
refuses to be mounted. In the Terminal, I get this error:

sudo ifuse /media/Mimtier/ -s
Failed to start AFC service 'com.apple.afc' on the device.

What does this mean? Can anything be done about it? It seems to me that
there is no iFuse version for Oneiric available although I still can get
iFuse through Synaptic.

Thanks for a short feedback

Hajo

Comments and changes to this ticket

  • Martin S.

    Martin S. May 31st, 2012 @ 10:00 AM

    • State changed from “new” to “open”

    Thanks for your report.

    A few questions:
    What (error) message you get on "... Nautilus ... refuses to be mounted" in detail?
    Why do you "sudo"? You know that you don't need that and can unmount using "fusermount -u "?
    Why do you add the "-s" option?
    Which version of libimobildevice is your system using and which iOS version is running on your iPod?

    Please run ifuse again. pass it the "--debug" option and post the output again.

  • Hajo Baess

    Hajo Baess May 31st, 2012 @ 11:51 AM

    Thanks for the prompt reply. I will do my homework and get back at you soon.

    kind regards

    Hajo

  • Hajo Baess

    Hajo Baess June 6th, 2012 @ 04:14 PM

    Here I am again after an absence for a couple of days.
    To get back to your comments:

    When I do

    sudo ifuse /media/Mimtier/ -s

    I get:

    Failed to start AFC service 'com.apple.afc' on the device.

    That's all.

    Why do you "sudo" Frankly, I copied the instruction from a Howto on the Net. It is not my own idea.

    Why do you add the "-s" option? See above...

    Which version of libimobildevice is your system using and which iOS version is running on your iPod? On my system (64bit) I have libimobildevice2 version 1.1.1-1ubuntu1, and the iPod Touch has iOS 5.1.1 (9B206)

    When I do:

    ifuse -debug

    I get:

    ERROR: No mount point specified

    Hope that this is what you want to know. I have created a folder "Mimtier" in /media already, but to no avail. Maybe something else is missing...

    When I try to mount the iPod in Nautilus, I get a complaint about rights (error -15). The iPod is FAT-formatted under Windows.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

A project around supporting the iPhone in Linux.

See http://libimobiledevice.org

People watching this ticket

Pages