#209 ✓invalid
Steffan Harris

Problems mounting iPhone 3GS

Reported by Steffan Harris | April 3rd, 2011 @ 06:59 PM

Problem: Cannot mount iPhone 32GB 3GS on Debian Squeeze running KDE 4.4.5, libimobiledevice 1.0.6, usbmuxd & libusbmuxd-dev 1.0.4, ifuse 1.0.0, gvfs & gvfs-backends 1.6.4, libplist 1.3. Also installed is kio_afc.

ifuse mounts the filesystem, ideviceinfo prints a long list of information (password protection is switched off). Plugging the device in displays a 'camera' notification, leaving ~/.gvfs empty.

Comments and changes to this ticket

  • Martin S.

    Martin S. April 30th, 2011 @ 03:36 PM

    • State changed from “new” to “invalid”
    • Tag set to automount, kde

    Since ifuse mounts fine and ideviceinfo prints the information, your libimobiledevice stack is correctly setup and working. No bug here.
    Setting up GVFS on a KDE desktop is not really an issue we need to solve in libimobiledevice. Please refer to your distro bugtracker.

    KDE in general has no automounting support and does not support libimobiledevice natively. Thus you will either have to setup some udev rule to automount your device with ifuse or perhaps you are simply missing the AFC gvfs backend (perhaps gvfs-backend-afc package?).

    Whatever, your issue is to setup GVFS on KDE including it's monitors, which apparently is not really working on your system.

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

A project around supporting the iPhone in Linux.

See http://libimobiledevice.org

People watching this ticket

Tags

Pages